Jump to content
  • 0
Sign in to follow this  
ariksaja

Another method gain your "NVIDIA" QE/CI,Clean without inject , Tested in SL and LION!

Question

Hello Guys! I'm so happy and relieved that apparently i found a way to make my NVIDIA Graphics Cards works OOB I testing it using "Zotac NVIDIA 8400 GS 512 MB DDR3"

I already testing in Snow Leopard 10.6.8 , and also Lion 10.7 - 10.7.2

Below version i didn't test it yet.

preparation :

1.Retail Snow Leopard 10.6.x (bought from apple)

2.Official Combo Update 10.6.8 v.1.1

3.MB{censored}

4.iB{censored} note : you can find MB{censored} and iB{censored} from here

5.Nvidia update QUADRO MAC OS X DRIVER RELEASE 256 which u can direct download it here *TESTED*

optional : i still didn't try it, but if your card support NVIDIA CUDA 3.2 FOR MAC RELEASE, direct download it in here*NOT TESTED* You may post if you testing it and works, share with your friends and colleagues.

Steps:

1.Install Snow Leopard

2.SL 10.6.8 Official Combo Update 10.6.8 v.1.1 you may test it first by reboot, is your card known ? or ... go to step 3

3.Do not reboot, let it finish until he told you to restart, let it be and install MB{censored}. i like MB{censored} 4.0.x because i can boot snow leopard also lion , you may try another such as chameleon latest version .

4.Reboot , and voila... my Graphics card running without injecting, without EFI, without dsdt , and natively working!!! and of course, ALL PORT ARE WORKING including HDMI, you may try dual monitor to try it. i already tried and all working great.

here is preview in system profiler:

oobk.jpg

By arikstress at 2011-11-01

screenshot20111105at124.jpg

By arikstress at 2011-11-01

i was trying with injecting method, nvenabler, etc. but i never has like this smoothness. oh well better use original driver than using modified or hacked driver. less hack is better to make stability of the system.

want to know fun fact? based on : nvidia link

Supported Type for this driver is :

GeForce 300M series:

GT 330M, GT 320M

GeForce 200 series:

GTX 285 for MAC

GeForce 100 series:

GT 120

GeForce 9M series:

9400M

GeForce 8 series:

8800 GT

GeForce 8M series:

8800M GTS, 8800M GS

Quadro series:

4000 for Mac

Quadro FX series:

FX 5600, FX 4800 for MAC

If you had run perfectly on Snow Leopard 10.6.8 , then you shouldn't be problem upgrading and running LION 10.7 - 10.7.2 after you installed this official driver on your system. i personally testing it, without install and with installing this drive is so different. After upgrading to Lion, yup it will not work, but hey, you can see Apple Logo on start up just like when your card working. It will still detect your card name and id, but main dependencies next will not loading. Why? Because Lion driver is newest, and Don't worry, you just have to do this after your upgrade , even only upgrading from 10.7 - 10.7.1 , or so on.

*Copy your /System/Library/Extensions/NVDANV*Hal.kext into your desktop

*Install it again with Kext Utility for Lion, and reboot. to make sure, boot and choose verbose mode ( -v ) and if you see NVDANV*Hal Loaded and Registered , voila, congratulations... you will have no trouble now and can use it freely without afraid being freeze :headbang: ;) :headbang:

Yup... my 8400GS is not listed. but yeah it's working. i think another card also supported, especially nvidia released at 2011

Come on Guys, testing and report it!

Edited by ariksaja

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
did it.

The EFI String inside the pack, (the one for my card, i mean geforce 8600 gt 512) didn,t load...

But if I use the one generated by EFI Studio, I´vegot the correctr resolution with Q/CI enabled.

Obviouslly, no posibility at all to connect the DVI port: same result: blank screen, reboot needed...

I don´t want to give up, so La puta madre!

But i´m now on the way to run an original fresh install and try.

By the way, this is what i see at the PCI cards, Is it same as your?

GeForce 8600 GT:

Name: NVDA,Display-B

Type: Display Controller

Driver Installed: Yes

MSI: Yes

Bus: PCI

Slot: Slot-1

Vendor ID: 0x10de

Device ID: 0x0401

Subsystem Vendor ID: 0x1682

Subsystem ID: 0x0010

ROM Revision: 60.84.43.00.81

Revision ID: 0x00a1

Link Width: x16

Link Speed: 2.5 GT/s

Just wanna know if we really share the same geforce card...

Yes...

Even the same DeviceID...

And the mine works with any kind of activation (GraphicsEnabler, EFI-String, DSDT, kext)...

Share this post


Link to post
Share on other sites
  • 0
Yes...

Even the same DeviceID...

And the mine works with any kind of activation (GraphicsEnabler, EFI-String, DSDT, kext)...

let´s see...

can you connect both the monitor to the vga output and other (a lcd tv or monitor) to you dvi output at same time and get working the two of them?

Share this post


Link to post
Share on other sites
  • 0
let´s see...

can you connect both the monitor to the vga output and other (a lcd tv or monitor) to you dvi output at same time and get working the two of them?

Yes, but like I told, I need to use a VGA to DVI adapter...

And i agree with ariksaja...

The only difference for me and you is the installation method...

If you want, just to made a test, i will send to you the same EFI-String that I use, but I think that the result will be the same...

Share this post


Link to post
Share on other sites
  • 0

guys, I tried the instructions at the beginning of the thread and almost royally screwed something up. Perhaps I didn't understand them correctly, but I extracted the nvidia installer, and manually installed the kexts within. after that I couldn't boot. maybe you could go into a little more detail? I'd really like to get my HDMI port working. I'm running a Dell XPS M1530 with nVidia GeForce 8600M GT 256 (?) might be 512. I'll have to look.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.