Jump to content
Sign in to follow this  
camerongray

[GUIDE] Use more than 4gb RAM on AMD with 32 and 64 bit apps working

Recommended Posts

Thanks a lot! worked on my computer, see my specs.

Run if i flag -force64 arch=i386 , but if i put arch=x86_64 have a kp says "system uptime in nanoseconds..."

Whats better? -force64 + arch=i386 or arch=x86_64?

Thanks

Share this post


Link to post
Share on other sites

So this method Works in Lion 10.7.3??? i have successful installed Lion on My AMD Phenom II x4 (check my Signature) and some applications Like a Diablo 3 and STEAM still running soooooo laggy! How to fix that?

Share this post


Link to post
Share on other sites

it worked for me very goood. you saved my life.

Now everything is working perfect... Final Cut X - iMovie - Photoshop CS5.5 in Snow Leopard 10.6.8

if anyone needed help.. please ask

@Gabrielayumi how you managed to install lion? which kernal you used?

10.6.8 OS X Snow Leopard - MSI 790 Phenom II x4 965 3.2Ghz 12GB DDR3 1600Mhz ATI HD5450

Share this post


Link to post
Share on other sites
it worked for me very goood. you saved my life.

Now everything is working perfect... Final Cut X - iMovie - Photoshop CS5.5 in Snow Leopard 10.6.8

if anyone needed help.. please ask

@Gabrielayumi how you managed to install lion? which kernal you used?

10.6.8 OS X Snow Leopard - MSI 790 Phenom II x4 965 3.2Ghz 12GB DDR3 1600Mhz ATI HD5450

Just follow the Experimental Guide here... method 2 with kernel of 10.7.3 AMD and iAtkos L2 [AMD] 10.7.3 Guide - Experimental Only - InsanelyMac Forum

Share this post


Link to post
Share on other sites

Confirming this patch works for me too. just for those who concerns, I am using AnV kernel as listed at signature section.

Thanks camerongray and this indeed helps a lot of people!!!

Btw terminal giving me a warning as attached screenshot. it seems no harm but annoying. adding -f bootflag doesn't help.

post-341729-137746144131_thumb.jpg

UPDATED JUN-26

I get rid of the warning message by a simple command, here is the sources.

sudo update_dyld_shared_cache -force

Edited by semson

Share this post


Link to post
Share on other sites

Hm, I have the same problem, non-AMD hackintosh with Snow Leopard installed but only able to see 4GB of my 8GB RAM. It says I have 8GB in there, and sees both dimms in there, but in the hardware overview in the System Profiler, it only recognizes 4GB. My mobo (Asus P5G41T M LX Plus) is not able to configure AHCI in BIOS. This is the 2nd mobo I've gotten for this hackintosh, trying to get it configured correctly. Any help would be appreciated!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.